Office 365 – SharePoint Online – Declare Record Field Value Has a Different Time Zone

Written by Denis Stadler on . Posted in Office 365

I have a SharePoint Online site collection, which has the In Place Record Management site collection feature enabled.

I have created also a document library, where I upload invoices and declare them as records, in order to enforce a 5 years retention policy. The problem is that, the time value in the Declared Record field of the item has a different value then the one showed by the system’s clock. It seems that it is working on another time zone.

The question is: am I missing something or it is a problem with my SharePoint Online site collection?

You can find below the screen shots containing:

  • My user’s regional settings
  • The regional settings from site administration

Update 1: I have sent a ticket with this issue to Office 365 support team.

Update 2: Just spoke with MSF. It seems that this issue is by design. All Office 365 SharePoint instances are using PST time zone, when it comes to record declaration. I’m now waiting for the e-mail confirmation.

Ticket Resolution: When declared document in the document library than upload time shows correct upload time but when check the document properties in SharePoint site it shows PST time and not an upload time. Involved an operations teams and they have confirmed that this is by design. So all we can do is to hope that the audit team won’t realise the time difference! :)

Tags: , ,

Trackback from your site.

Denis Stadler

I'm a technology enthusiast, with more than 10 years of experience in SharePoint and Dynamics CRM projects. To find more details about, please visit the about me page.

Leave a comment

*